|VRNG(4)||Device Drivers Manual (sparc64)||VRNG(4)|
vrng0 at vbus?
vrngdriver provides support for the random number generation service provided by the UltraSPARC Hypervisor as found on sun4v systems.
Driven by periodic checks for available data from the generator,
vrng supplies entropy to the
random(4) driver for common usage.
vrngdriver first appeared in OpenBSD 4.5.
vrngdriver was written by Mark Kettenis <firstname.lastname@example.org>.
vrngdriver should probably do periodic “health checks” when running in a Trusted Domain, but currently does not.
|July 16, 2013||OpenBSD-current|