|VRELE(9)||Kernel Developer's Manual||VRELE(9)|
vrele — decrement
the use count for a vnode
Decrement the v_usecount field of the vnode specified by vp.
Any code in the system which uses a vnode should call
vrele() when it is finished with the vnode. If the
v_usecount field of the vnode reaches zero, the vnode
will be placed on the free list.
vrele() returns 0 if it can guarantee that
it did not sleep.
This man page was originally written by Doug Rabson for FreeBSD.
|June 4, 2013||OpenBSD-current|