|VGET(9)||Kernel Developer's Manual||VGET(9)|
vget — get a vnode
from the free list
vnode *vp, int
Get a vnode from the free list and increment its reference count.
Its arguments are:
When not in use, vnodes are kept on a free list. The vnodes still reference valid files but may be reused to refer to a new file at any time. Often, these vnodes are also held in caches in the system, such as the name cache.
When a vnode which is on the free list is used again, for instance
if the vnode was found in the name cache as a result of a call to
VOP_LOOKUP(9), then the new user must
vget() to increment the reference count and
remove it from the free list.
This man page was originally written by Doug Rabson for FreeBSD.
|May 27, 2018||OpenBSD-current|