|VIAPM(4)||Device Drivers Manual||VIAPM(4)|
viapm* at pci?
iic* at viapm?
viapmdriver provides support for the bus control and power management component of the VIA VT82C596, VT82C596B, VT82C686A, VT8231, VT8233, VT8233A, VT8235, VT8237, VT8237A, VT8237S, VT8251, CX700, VX800, VX855 and VX900 South Bridges. Only the SMBus host interface is supported and can be used with the iic(4) framework.
viapm driver provides support for the
hardware monitor in the VIA VT82C686A and VT8231 South Bridges. The hardware
monitor is used with the sysctl(8)
The device has 10 sensors:
||uV DC||CPU core voltage (2.0V)|
||uV DC||North Bridge core voltage (2.5V)|
||uV DC||Internal core voltage (3.3V)|
Sensor data is updated every 1.5 seconds.iic(4), intro(4), pci(4), sensorsd(8), sysctl(8)
viapmdriver first appeared in OpenBSD 3.9.
viaenv driver first appeared in
NetBSD 1.5. OpenBSD support
was added in OpenBSD 3.4.
viapmdriver was written by Mark Kettenis <firstname.lastname@example.org>.
viaenv driver was written by
Johan Danielsson and ported to
OpenBSD 3.4 by Alexander
It was merged with
viapm in OpenBSD
Interrupt support is unimplemented, as is support for setting values.
|July 5, 2018||OpenBSD-current|