|RCSFILE(5)||File Formats Manual||RCSFILE(5)|
rcsfile — format
of an RCS file
An RCS file is a text file. It consists of four sections, each separated by two empty lines. RCS files should not be edited by hand; the rcs(1) programs should be used instead.
The RCS file begins with admin data. Each entry in this section consists of either one or multiple values. Entries that take one value are specified on one line: The keyword and its corresponding value are separated by a tab character. Entries that take multiple values begin with a keyword on one line; the values are specified on subsequent lines, one per line and prefixed with a tab character. If the list is empty, the semicolon immediately follows the keyword. Entries are terminated with a semicolon. The entries are:
The RCS file continues with a list of deltas. Deltas are separated by empty lines. The list begins with the head and ends with the initial revision. Each entry begins with the revision number, followed by a newline. After that, the structure follows the admin section.
datewithout a newline.
authorwithout a newline.
The RCS file continues with the description. It consists of the
desc followed by a newline and then an at
sign. The description is an arbitrary string that can span multiple lines. A
single at sign on a line terminates the description. At signs anywhere in
the description itself are escaped by prefixing them with another at
Finally, the RCS file contains the deltatexts. The list of
deltatexts is ordered the same as the list of deltas. Deltatexts are
separated by two lines. Each entry begins with the revision number, followed
by a newline. The text “
on its own line. The log message follows on another new line; it consists of
an at sign, the log message itself (which may span multiple lines), and
finally an at sign on its own line. Then the text
text” follows on its own line. The
format is the same as for the description and log message. As with the
description, at signs anywhere in the log message or in the deltatext itself
are escaped by prefixing them with another at sign. The deltatext of the
head consists of the full file contents. All subsequent deltatexts contain
the differences to the previous deltatext in the format of
|April 24, 2019||OpenBSD-current|