|OWSBM(4)||Device Drivers Manual||OWSBM(4)|
owsbm — 1-Wire
smart battery monitor device
owsbm* at onewire?
owsbm driver provides support for the
1-Wire smart battery monitor. The sensor possesses a temperature sensor, an
A/D converter for measuring both battery voltage and current, a current
accumulator of both incoming and outgoing current, an elapsed time and 40
bytes of nonvolatile EEPROM.
Only the three voltages (VDD, VAD, CR) and temperature are accessible by the sysctl(8) interface.
The following chips are supported by the driver:
The sensor does not measure current directly. Instead it measures the voltage across the Rsens pins.
I = Voltage CR / Rsens (where Rsens is in Ohms)
owsbm driver first appeared in
owsbm driver was written by
|July 16, 2013||OpenBSD-current|