|BOOT(8)||System Manager's Manual (macppc)||BOOT(8)|
— macppc-specific bootstrap
The main purpose of this program is to load the system kernel.
As described in boot_macppc(8), this program is loaded by the firmware and provides a convenient way to load the kernel. This program acts as an enhanced boot monitor for macppc systems, providing a common interface for the kernel to start from.
Basic operations include:
The sequence of its operation is as follows: initialization,
parsing the configuration file, then an interactive command line. While at
the command line you have 5 seconds to type any commands, if needed. If time
expires, the kernel will be loaded according to the current variable
settings (see the
set command). Each time a kernel
load fails, the timeout is increased by one second. The sequence of
boot operations is as follows:
bootaccepts at the interactive prompt. Though default settings usually suffice, they can be changed here.
>> OpenBSD/macppc BOOT [x.xx]
is displayed to the active console, where
x.xx is the version number of the
boot program, followed by the
prompt, which means you are in interactive mode and may enter
commands. If you do not,
boot will proceed to
load the kernel with the current parameters after the timeout period has
boot attempts to load the
kernel executable /bsd. If it fails to find the
kernel and no alternative kernel image has been specified, the system will
be unable to boot.
The following commands are accepted at the
bootvariables will be used.
The only bootable devices, at the moment, are IDE devices connected to the internal controller; they are detected as ‘wd’ devices. Therefore, to boot kernel /bsd from slice ‘a’ on the first hard drive, specify “boot wd0a:/bsd”.
bootwas compiled with DEBUG defined.
Boot the default kernel:
Remove the 5 second pause at boot-time permanently, causing
boot to load the kernel immediately without
# echo "boot" > /etc/boot.conf
Boot the kernel named /bsd from the second
hard disk in “User Kernel Configuration” mode (see
boot_config(8)). This mechanism
allows for the explicit enabling and disabling of devices during the current
boot sequence, as well as the modification of device parameters. Once
booted, such changes can be made permanent by using
boot> boot wd1a:/bsd -c
This program was written by Michael Shalayeff for OpenBSD 2.1 on the i386 platform, and was later ported to the macppc platform.
|December 23, 2019||OpenBSD-current|