OpenBSD manual page server

Manual Page Search Parameters

RIPD.CONF(5) File Formats Manual RIPD.CONF(5)

ripd.confRIP routing daemon configuration file

The ripd(8) daemon implements the Routing Information Protocol version 2 as described in RFC 2453.

The ripd.conf config file is divided into the following main sections:

User-defined variables may be defined and used later, simplifying the configuration file.
Global settings for ripd(8).
Interface-specific parameters.

Much like cpp(1) or m4(1), macros can be defined that will later be expanded in context. Macro names must start with a letter, digit, or underscore, and may contain any of those characters. Macro names may not be reserved words (for example, cost). Macros are not expanded inside quotes.

For example:

hi="2"
interface em0 {
	cost $hi
}

Global settings concerns the main behaviour of the daemon.

prio
Set the routing priority to prio. The default is 40.

(yes|no)
If set to no, do not update the Forwarding Information Base, a.k.a. the kernel routing table. The default is yes.

tableid
Specifies the routing table ripd(8) should modify. Table 0 is the default table.

[no] redistribute (static|connected|default)
 
[no] redistribute prefix
 
[no] redistribute rtlabel label
If set to connected, routes to directly attached networks will be announced over RIP. If set to static, static routes will be announced over RIP. If set to default, a default route pointing to this router will be announced over RIP. It is possible to specify a network range with prefix; networks need to be part of that range to be redistributed. Additionally it is possible to redistribute based on route labels using the rtlabel keyword. By default no additional routes will be announced over RIP.

redistribute statements are evaluated in sequential order, from first to last. The first matching rule decides if a route should be redistributed or not. Matching rules starting with no will force the route to be not announced.

(simple|poisoned|none)
If set to simple, do not redistribute routes to the interface from which they were learned. If set to poisoned, redistribute routes to the interface from which they were learned, by forcing the metric to infinity. Both these behaviours can resolve routing loops when a router goes down. The default is poisoned.

(yes|no)
Immediately trigger responses when a route changes. The default is no.

Each interface can have several parameters configured individually, otherwise they are inherited.

interface em0 {
	cost 9
	auth-type none
}
interface ix1

Interface-specific parameters are listed below.

key
Set the authentication key for simple authentication. Up to 16 characters can be specified.
key-id key
Set the authentication key-id and key for crypt authentication. The valid range for key-id is 0-255. Up to 16 characters can be specified for key. Multiple keys may be specified.
key-id
Configure the key-id to use for crypt authentication. The valid range for key-id is 0-255. The default key-id is 1.
(none|simple|crypt)
Set the authentication type. The default is none. Simple authentication uses a plaintext password, up to 16 characters. Crypt authentication uses an MD5 hash.
number
Cost of the network connected through this interface. Values must be between 1 and 16, inclusive.
group
Increase the carp(4) demotion counter by 1 on the given interface group, usually carp, when the interface state is going down. The demotion counter will be decreased when the interface state is active again.
Prevent transmission and reception of RIP packets on this interface.

/etc/ripd.conf
ripd(8) configuration file.
/etc/examples/ripd.conf
Example configuration file.

rc.conf.local(8), ripctl(8), ripd(8)

The ripd.conf file format first appeared in OpenBSD 4.1.

March 2, 2023 OpenBSD-current