|ADB(4)||Device Drivers Manual (macppc)||ADB(4)|
adb0 at macobio?
abtn* at adb?
akbd* at adb?
ams* at adb?
apm0 at adb?
piic0 at adb?
Originally developed for the Mac68K port, the
adb driver was heavily modified when it was ported
to the PowerPC architecture. During this port it seems that the original
adb event device was split into many smaller
adb devices such as the Apple
Brightness / Volume Control Button
(abtn(4)), some energy control
(apm(4)), and I2C controller
(piic(4)) were added to the PowerPC port
later to complement the ADB system.
OpenBSD provides support for the following devices:
adbinterface first appeared in NetBSD 0.9. It has been under development ever since. The original
adbmanpage was written by Colin Wood for NetBSD/Mac68K.
|January 15, 2015||OpenBSD-current|