|BIOS(4)||Device Drivers Manual (i386)||BIOS(4)|
bios0 at mainbus0 flags 0x0000
apm0 at bios0 flags 0x0000
pcibios0 at bios0 flags 0x0000
bios driver also identifies BIOS type
(such as "AT/286+", which is almost always used in modern
machines) and BIOS image date stamp, which is, presumably, the day the BIOS
image was compiled by vendor and could be used as a crude BIOS version
bios driver also scans the ISA
memory hole at 640K-1M for optional ROM images and reserves the space from
being used by various ISA devices, for example
Flags is a bit mask, each bit of which specifies which functions of the driver to disable.
Do not probe or attach to BIOS32 extensions. BIOS32 is one of the interfaces to the PCI BIOS configuration tables.
Do not probe or attach the pcibios(4) device, which performs certain PCI configuration tasks.
Do not probe or attach to SMBIOS. SMBIOS provides greater detail about system hardware configuration and is required to attach ipmi(4) on most systems.
biosdriver appeared in OpenBSD 2.2.
|May 31, 2007||OpenBSD-current|