|GPIOIIC(4)||Device Drivers Manual||GPIOIIC(4)|
gpioiic — GPIO I2C
gpioiic* at gpio? offset 0 mask 0x3 flag
gpioiic* at gpio?
iic* at gpioiic?
gpioiic driver allows bit-banging an
I2C bus as a master using two GPIO pins. By default the first pin is used as
a serial data (SDA) signal and the second as a serial clock (SCL). If the
flag locator is set to 0x01, the order of the SDA and SCL signals is
reversed. Both GPIO pins must be able to drive an output and the SDA pin
must be also able to read an input.
The pins can be specified in the kernel configuration with the
offset and the mask locators.
The offset and mask can also be
gpioiic is attached at runtime using
ioctl(2) on the
gpio(4) device. Each bit in the
mask locator defines one pin; the pin number is
calculated as an addition of the bit position and the
offset locator. For example, offset
17 and mask 0x5 defines pin numbers 17 and
gpioiic driver first appeared in
gpioiic driver was written by
|July 16, 2013||OpenBSD-current|