|FSIRAND(8)||System Manager's Manual||FSIRAND(8)|
fsirandcommand installs random generation numbers on all the inodes for each filesystem specified on the command line by special. This increases the security of NFS-exported filesystems by making it difficult to “guess” filehandles.
now does the equivalent of
fsirand itself so it is
no longer necessary to run
fsirand by hand on a new
filesystem. It is only used to re-randomize or report on an existing
fsirand should only be used on an
unmounted filesystem that has been checked with
fsck(8) or a filesystem that is mounted
fsirand may be used on the root
filesystem in single-user mode but the system should be rebooted via
“reboot -n” afterwards.
The options are as follows:
fsirandto run even if the filesystem on special is not marked as clean.
fsirandcommand appeared in SunOS 3.x. This version of
fsirandfirst appeared in OpenBSD 2.1.
fsirandallocates enough memory to hold all the inodes in a given cylinder group, it may use a large amount of memory for large disks with few cylinder groups.
|January 25, 2019||OpenBSD-current|