|CLRI(8)||System Manager's Manual||CLRI(8)|
||special_device inode_number ...|
clriis obsoleted for normal file system repair work by fsck(8).
clri zeros out the inodes with the
specified inode numbers on the filesystem residing on the given
fsck(8) utility is usually run after
clri to reclaim the zero'ed inodes and the blocks
previously claimed by those inodes. Both read and write permission are
required on the specified special_device.
The primary purpose of this routine is to remove a file which for some reason is not being properly handled by fsck(8). Once removed, it is anticipated that fsck(8) will be able to clean up the resulting mess.
clriwill be lost when the inode is written back to disk from the inode cache.
|August 6, 2007||OpenBSD-current|