|BGPLGSH(8)||System Manager's Manual||BGPLGSH(8)|
bgplgshprogram is a looking glass shell for the bgpd(8) Border Gateway Protocol daemon. The looking glass will provide a simple command line interface with read-only access to a restricted set of bgpd(8) and system status information, which is typically used on route servers by Internet Service Providers (ISPs) and Internet eXchange points (IXs).
It requires three steps to enable the looking glass shell:
bgplgshas a valid login shell. See shells(5) for more information.
# echo /usr/bin/bgplgsh >> /etc/shells
# adduser -shell /usr/bin/bgplgsh -batch bgplg # passwd bgplg
For example, add the following to /etc/bgpd.conf to have bgpd(8) open a second, restricted, control socket:
socket "/var/www/run/bgpd.rsock" restricted
bgplgshprogram first appeared in OpenBSD 4.1. The initial implementation was done in 2005 for DE-CIX, the German commercial internet exchange point.
bgplgshprogram was written by Reyk Floeter <email@example.com>.
bgplgshwill kill the corresponding processes after a hard limit of 60 seconds. For example, this can take effect when using traceroute(8) with blackholed or bad routes.
|September 10, 2015||OpenBSD-current|