|ASMC(4)||Device Drivers Manual||ASMC(4)|
asmc0 at isa? port 0x300
asmcdriver provides support for the Apple System Management Controller (SMC), as found in Intel based Apple devices.
The driver possesses a collection of temperature, fan, light, and acceleration sensor values which are made available through the sysctl(8) interface.
If available, the keyboard backlight is enabled by the driver and can be adjusted using the wsconsctl(8) variable keyboard.backlight.
asmcdriver first appeared in OpenBSD 5.9.
asmcdriver was written by Joerg Jung <firstname.lastname@example.org>.
Acceleration sensors are not available and the associated interrupt handling is not implemented.
Besides the sensors, the huge amount of other functions and information available from the SMC is not supported.
|December 12, 2015||OpenBSD-current|