|WSCONSCTL(8)||System Manager's Manual||WSCONSCTL(8)|
] name ...
] name=value ...
wsconsctlcommand displays or sets various wscons system driver variables. If a list of variables is present on the command line,
wsconsctlprints the current value of those variables for the specified device. The options are as follows:
=’ symbol, or as a relative value, by using the ‘
+=’ or ‘
-=’ symbols. See the EXAMPLES section for more details.
wsconsctlutility can be used to view and modify aspects of the keyboard, display, and mouse using the standard, machine-independent workstation console device driver wscons(4). The keyboard type can be modified, the keyboard bell's pitch, period, and duration can be modified, the typematic value can be changed, and the keyboard encoding can be modified to switch keys, should the user find a keyboard's default layout difficult to use. There are also definitions relating to video control and cursor control, which are not applicable to all display types, and to text emulation and graphics (mapped) modes. Use the kbd(8) utility to determine which keyboard encodings are available for your country. A keyboard mapping can also be specified in /etc/kbdtype.
# wsconsctl keyboard.encoding=uk
# wsconsctl keyboard.map+="keysym Caps_Lock = Control_L"
# wsconsctl keyboard.map+="keycode 184=Mode_switch"
# wsconsctl keyboard.map+="keycode 157=Mode_Lock"
# wsconsctl keyboard.encoding=us.swapctrlcaps
# wsconsctl keyboard.bell.pitch=1200
# wsconsctl keyboard.bell.pitch+=200
# wsconsctl display.font=Gallant
wsconsctlcommand first appeared in NetBSD 1.4 and OpenBSD 2.8.
|May 27, 2017||OpenBSD-current|