|ASMC(4)||Device Drivers Manual||ASMC(4)|
asmc — Apple
System Management Controller (SMC)
asmc0 at acpi?
asmc driver provides support for the
Apple System Management Controller (SMC), as found in Intel based Apple
The driver possesses a collection of temperature, fan, light, and acceleration sensor values which are made available through the sysctl(8) interface.
If available, the keyboard backlight is enabled by the driver and can be adjusted using the wsconsctl(8) variable keyboard.backlight.
asmc driver first appeared in
asmc driver was written by
Light sensor values may not be available on older products.
Acceleration sensors are not available and the associated interrupt handling is not implemented.
Besides the sensors, the huge amount of other functions and information available from the SMC is not supported.
|September 13, 2020||OpenBSD-current|