|AN(4)||Device Drivers Manual||AN(4)|
an* at pcmcia?
an* at pci?
an* at isapnp?
andriver provides support for the Aironet Communications 4500, 4800 (aka Cisco 340), and Cisco 350 IEEE 802.11 wireless network adapters. This includes the ISA, PCI, and PCMCIA varieties. The 4500 series adapters operate at 1 and 2Mbps (FH) while the 4800 and 350 series can operate at 1, 2, 5.5, and 11Mbps (DS). The ISA, PCI, and PCMCIA devices are all based on the same core PCMCIA modules and all have the same programming interface. However, unlike the Lucent WaveLAN/IEEE cards, the ISA and PCI cards appear to the host as normal ISA and PCI devices and do not require any PCMCIA support.
ISA cards can either be configured to use ISA Plug and Play or to
use a particular I/O address and IRQ by properly setting the DIP switches on
the board. (The default switch setting is for plug and play.) The
an driver has Plug and Play support and will work in
either configuration, however when using a hard-wired I/O address and IRQ,
the driver configuration and the NIC's switch settings must agree. PCI cards
require no switch settings of any kind and will be automatically probed and
All host/device interaction with the Aironet cards is via
programmed I/O. The
an driver encapsulates all IP
and ARP traffic as 802.11 frames, though it can receive either 802.11 or
These are the modes the
an driver can
an driver can be configured to use
hardware Wired Equivalent Privacy (WEP). It is strongly recommended that WEP
not be used as the sole mechanism to secure wireless communication, due to
serious weaknesses in it.
nwid mynwid nwkey mywepkey dhcp
andevice driver first appeared in FreeBSD 4.0. OpenBSD support was added in OpenBSD 2.7. A version of the driver based on the one in NetBSD was added in OpenBSD 3.9.
andriver was written by Bill Paul <firstname.lastname@example.org> and ported to OpenBSD by Michael Shalayeff <email@example.com>. Later the NetBSD version of the driver by Atsushi Onoe was subsequently ported to OpenBSD by Jonathan Gray <firstname.lastname@example.org>.
|January 21, 2019||OpenBSD-current|