|AMI(4)||Device Drivers Manual||AMI(4)|
ami — American
Megatrends Inc. MegaRAID PATA/SATA/SCSI RAID controller
ami* at pci?
ami driver provides support for the
MegaRAID family of RAID controllers, including:
These controllers support RAID 0, RAID 1, RAID 5, JBOD, and superpositions of those configurations.
Although the controllers are actual RAID controllers, the driver makes them look just like SCSI controllers. All RAID configuration is done through the controllers' BIOSes.
The management interface is provided through the bio(4) device or one of the daughter sd(4) devices as implemented in the bioctl(8) utility. Logical disk status is exposed under the hw.sensors sysctl(8) and can be monitored using sensorsd(8). For example:
$ sysctl hw.sensors.ami0 hw.sensors.ami0.drive0=online (sd0), OK hw.sensors.ami0.drive1=degraded (sd1), WARNING hw.sensors.ami0.drive2=failed (sd2), CRITICAL
ami driver first appeared in
ami driver was written by
Management functions were implemented by Marco Peereboom <firstname.lastname@example.org>.
|November 4, 2013||OpenBSD-current|