|RELAYD(8)||System Manager's Manual||RELAYD(8)|
relaydis a daemon to relay and dynamically redirect incoming connections to a target host. Its main purposes are to run as a load-balancer, application layer gateway, or transparent proxy. The daemon is able to monitor groups of hosts for availability, which is determined by checking for a specific service common to a host group. When availability is confirmed, layer 3 and/or layer 7 forwarding services are set up by
Layer 3 redirection happens at the packet level; to configure it,
relayd communicates with
pf(4). To allow
relayd to properly set up
pf(4) rules, the following line is required
in the filter section of pf.conf(5):
Layer 7 relaying happens at the application level and is handled
relayd itself. Various application level
filtering and protocol-specific load-balancing options are available for
relayd works in terms of the following
entities: relays, protocols, redirections, and tables. A
relay represents a layer 7 load-balancing instance. Each
instance translates to a listening TCP or UDP port. A
protocol defines which actions, if any, are taken on the
packet payload as data crosses a relay. A redirection
represents a layer 3 load-balancing instance. Each instance translates to a
pf(4) rdr-to rule being added. A
table represents a group of hosts which can be checked for
availability using the same method. Each table contains at least one host.
If a table is used in a layer 3 load-balancing instance, it will be mapped
to a pf(4) table containing only those hosts
which are up.
The options are as follows:
relaydwill run in the foreground and log to stderr.
relaydprogram, formerly known as
hoststated, first appeared in OpenBSD 4.1. It was renamed to
relaydin OpenBSD 4.3.
relaydprogram was written by Pierre-Yves Ritschard <email@example.com> and Reyk Floeter <firstname.lastname@example.org>.
|July 27, 2015||OpenBSD-current|