|NTPD(8)||System Manager's Manual||NTPD(8)|
ntpd — Network
Time Protocol daemon
ntpd daemon synchronizes the local
clock to one or more remote NTP servers or local timedelta sensors.
ntpd can also act as an NTP server itself,
redistributing the local time. It implements the Simple Network Time
Protocol version 4, as described in RFC 5905, and the Network Time Protocol
version 3, as described in RFC 1305. Time can also be fetched from TLS HTTPS
servers to reduce the impact of unauthenticated NTP man-in-the-middle
The options are as follows:
ntpdwill run in the foreground and log to stderr.
ntpd will stay in the foreground for
up to 15 seconds waiting for one of the configured NTP servers to
ntpdto send DEBUG priority messages to syslog.
ntpd uses the
adjtime(2) system call to correct the
local system time without causing time jumps. Adjustments of 32ms and
greater are logged using syslog(3). The
threshold value is chosen to avoid having local clock drift thrash the log
ntpd be started with the
-v option, all calls
to adjtime(2) will be logged.
ntpd makes efforts to verify and correct
the time at boot if constraints are configured and satisfied or if trusted
servers or sensors return results, and if the clock is not being moved
After the local clock is synchronized,
ntpd adjusts the clock frequency using the
adjfreq(2) system call to compensate for
ntpd starts up, it reads settings
from its configuration file, typically
ntpd.conf(5), and its initial clock
drift from /var/db/ntpd.drift. Clock drift is
periodically written to the drift file thereafter.
David L. Mills, Network Time Protocol (Version 3): Specification, Implementation and Analysis, RFC 1305, March 1992.
David L. Mills, Jim Martin, Jack Burbank, and William Kasch, Network Time Protocol Version 4: Protocol and Algorithms Specification, RFC 5905, June 2010.
ntpd program first appeared in
|November 11, 2019||OpenBSD-current|