|PWD_MKDB(8)||System Manager's Manual||PWD_MKDB(8)|
generate the password databases
pwd_mkdb creates a pair of Berkeley
databases from file and installs them into
/etc/pwd.db. The file argument
is renamed to /etc/master.passwd.
The options are as follows:
-uflag during a password change. Because the insecure database doesn't contain the password there is no reason to update it if the only change is in the password field. Cannot be used in conjunction with the
The two databases differ in that the secure version contains the user's encrypted password and the insecure version has an asterisk (‘*’).
The databases are used by the C library password routines (see getpwent(3)).
pwd_mkdb utility exits 0 on
success, and >0 if an error occurs.
pwd_mkdb utility first appeared in
Because of the necessity for atomic update of the password files,
rename(2) to install them.
This, however, requires that the file specified on the command line live on
the same file system as the /etc directory.
There are the obvious races with multiple people running
pwd_mkdb on different password files at the same
time. The front-ends to
vipw(8) handle the locking
necessary to avoid this problem.
|September 10, 2017||OpenBSD-7.0|