|VWAKEUP(9)||Kernel Developer's Manual||VWAKEUP(9)|
vwakeup — update
outstanding I/O count and do wakeup on a vnode
function updates the number of outstanding I/O operations on the target
vnode, stored in its v_numoutput field. If the target
vnode has the
VBIOWAIT flag set in its
v_bioflag field and has no outstanding I/O operations
remaining, a wakeup(9) is
performed as well.
This document first appeared in OpenBSD 3.7.
vwakeup() more times than the
number of outstanding I/O operations will cause the system to
|August 14, 2013||OpenBSD-6.9|