|VWAITFORIO(9)||Kernel Developer's Manual||VWAITFORIO(9)|
vwaitforio — wait
for all outstanding asynchronous writes
vwaitforio(struct vnode *vp,
int slpflag, char *wmesg,
call sleeps until all asynchronous writes associated with the vnode
vp finish. This is used by functions that need to make
sure that the writes they initiated have completed.
This function must be called at splbio(9).
It may be important to ensure that no other
process submits asynchronous writes while a process is waiting for I/O on
this vnode. Otherwise,
may never return.
vwaitforio() function returns 0 on
success. See tsleep(9) for
possible error returns.
|July 19, 2019||OpenBSD-6.9|