|SHUTDOWN(8)||System Manager's Manual||SHUTDOWN(8)|
shutdown — close
down the system at a given time
shutdown provides an automated shutdown
procedure for superusers to nicely notify users when the system is shutting
down, saving them from system administrators, hackers, and gurus, who would
otherwise not bother with such niceties. When the
shutdown command is issued without options the
system is placed in single user mode at the indicated time after shutting
down all system services.
The options are as follows:
-rcauses system to perform a dump. This option is useful for debugging system dump procedures or capturing the state of a corrupted or misbehaving system. See savecore(8) for information on how to recover this dump.
-koption does not actually halt the system, but leaves the system multi-user with logins disabled (for all but superuser).
-rprevents the normal sync(2) before stopping the system.
-pflag is passed on to halt(8), causing machines which support automatic power down to do so after halting.
shutdownexecs reboot(8) at the specified time.
shutdownwill bring the system down and may be the word now (indicating an immediate shutdown) or specify a future time in one of two formats: +number, or yymmddhhmm, where the year, month, and day may be defaulted to the current system values. The first form brings the system down in number minutes and the second at the absolute time specified.
-’ is supplied as an option, the warning message is read from the standard input.
At intervals, becoming more frequent as apocalypse approaches and
starting at ten hours before shutdown, warning messages are displayed on the
terminals of all users logged in. Five minutes before shutdown, or
immediately if shutdown is in less than 5 minutes, logins are disabled by
creating /etc/nologin and copying the warning
message there. If this file exists when a user attempts to log in,
login(1) prints its contents
and exits. The file is removed just before
At shutdown time a message is written in the system log, containing the time of shutdown, who initiated the shutdown and the reason. A terminate signal is then sent to init to bring the system down to single-user state (depending on above options). The time of the shutdown and the warning message are placed in /etc/nologin and should be used to inform the users about when the system will be back up and why it is going down (or anything else).
You can cancel a scheduled shutdown with the kill(1) command by killing the shutdown process.
The hours and minutes in the second time format may be separated by a colon (‘:’) for backward compatibility.
shutdown command appeared in
|January 21, 2015||OpenBSD-6.9|