|SWITCH(4)||Device Drivers Manual||SWITCH(4)|
switch — network
switch pseudo device
switch driver provides a network
interface pseudo-device. The interface is the forwarding part of a network
switch and it works along with a controller, usually
switchctl(8), through the
device /dev/switchN. The
switch device and the controller communicate using
the OpenFlow 1.3 protocol.
switch interface is created using
create or by opening the character device
/dev/switchN is the OpenFlow channel of the interface switchN. It is used for exchanging OpenFlow messages. The device behaves like a stream, which means that a read(2) may return one or more OpenFlow messages depending on the number of bytes requested. It may also read the message partially (e.g. read(2) the OpenFlow message header and then the complete message). The same applies to write(2) calls, so it may send one or more OpenFlow messages with a single write or use more than one write(2) calls to send a single message.
SIOCBRDGADDLstruct ifbreq *
If open fails, errno(2) may be set to one of:
Open Networking Foundation (ONF), OpenFlow Switch Specification, Version 1.3.5 (Protocol version 0x04), March 26, 2015.
switch driver first appeared in
switch driver was written by
|October 24, 2017||OpenBSD-6.4|