OpenBSD manual page server

Manual Page Search Parameters

UHID(4) Device Drivers Manual UHID(4)

uhidUSB generic HID support

uhid* at uhidev?

The uhid driver provides support for all HID (Human Interface Device) interfaces in USB devices that do not have a special driver.

The device handles the following ioctl(2) calls:

Get the report identifier used by this HID report.
Get the HID report descriptor. Using this descriptor the exact layout and meaning of data to/from the device can be found. The report descriptor is delivered without any processing.
struct usb_ctl_report_desc {
    int     ucrd_size;
    u_char  ucrd_data[1024];	/* filled data size will vary */
};
Get a report from the device without waiting for data on the interrupt pipe. The report field indicates which report is requested. It should be UHID_INPUT_REPORT, UHID_OUTPUT_REPORT, or UHID_FEATURE_REPORT. This call may fail if the device does not support this feature.
struct usb_ctl_report {
	int	ucr_report;
	u_char	ucr_data[1024];	/* used data size will vary */
};
Set a report in the device. The report field indicates which report is to be set. It should be UHID_INPUT_REPORT, UHID_OUTPUT_REPORT, or UHID_FEATURE_REPORT. This call may fail if the device does not support this feature.

Use read(2) to get data from the device. Data should be read in chunks of the size prescribed by the report descriptor.

Use write(2) send data to the device. Data should be written in chunks of the size prescribed by the report descriptor.

usbhidctl(1), usbhid(3), intro(4), uhidev(4), usb(4)

The uhid driver appeared in OpenBSD 2.6.

February 28, 2016 OpenBSD-6.1