|hostctl(8/amd64)||display or modify contents of the host's key-value store|
|hostctl(8/i386)||display or modify contents of the host's key-value store|
|HOSTCTL(8)||System Manager's Manual||HOSTCTL(8)|
] key [
hostctlprogram provides a generic interface for accessing key-value stores on the system's host. It is primarily used for an abstracted way to exchange information with hypervisors that are supported by the pvbus(4) subsystem. When given the name of a specific key,
hostctlwill display the value or list the key names of the subtree. If the key is followed by a value,
hostctlwill write the new key-value pair to the key-value store. The options are as follows:
# hostctl guestinfo.hostname vm-111.example.com # hostctl guestinfo.ip 192.168.100.111
# hostctl device/vif/0/mac fe:e1:ba:d0:27:0f # hostctl device/vif/0/description "My interface"
# hostctl device vfb vbd vif console
# hostctl Auto/ FullyQualifiedDomainName IntegrationServicesVersion NetworkAddressIPv4 NetworkAddressIPv6 OSBuildNumber OSName OSMajorVersion OSMinorVersion OSVersion ProcessorArchitecture # hostctl Auto/FullyQualifiedDomainName `hostname`
hostctlprogram first appeared in OpenBSD 5.9.
hostctlprogram was written by Reyk Floeter <email@example.com>.
|January 18, 2017||OpenBSD-6.1|