|BGPD(8)||System Manager's Manual||BGPD(8)|
bgpd — Border
Gateway Protocol daemon
bgpd is a Border Gateway Protocol (BGP)
daemon which manages the network routing tables. Its main purpose is to
exchange information concerning "network reachability" with other
bgpd uses the Border Gateway Protocol,
Version 4, as described in RFC 4271.
BGP is an exterior gateway protocol using a multiple step decision
process to find the best path. Advanced filtering can be used to influence
the route decision for traffic engineering. The session engine of
bgpd is responsible for maintaining the TCP session
with each neighbor. Updates are passed to the Route Decision Engine (RDE)
where the paths are filtered and used to compute a Routing Information Base
(RIB). The parent process is responsible for keeping the RIB in sync with
the kernel routing table.
The route decision process selects the best path by evaluating all paths to the same destination. The decision process continues to the next step if paths have equal attributes. Paths that are less preferred are taken out of consideration until there is only one path left.
rde med compare always” is set in the configuration, the metric is compared for routes sent by any AS.
rde route-age evaluate” is set then the oldest path is selected.
bgpdwill prefer statically set prefixes over dynamically inserted ones.
Attributes set by filters can be used to tip the decision process to prefer particular paths over others. This can be achieved by changing the localpref, med, or weight attributes. AS path prepending or changing the med or origin attribute can be used to influence the routing behaviour on remote systems.
bgpd is usually started at boot time, and
can be enabled by setting the following in
The options are as follows:
bgpdto do carp(4) demotion at startup when the demote functionality is used. Normally,
bgpdwill only do demotion at startup when the demotion counter for the group in question is already greater than 0.
bgpdwill start handling demotion after all sessions with demotion configured for the given group have been successfully established. At system startup, rc(8) has the demotion counter for the group carp increased until after
bgpdis started, so this option should not be used in rc.conf(8).
bgpdwill run in the foreground and log to stderr.
R. Chandra, P. Traina, and T. Li, BGP Communities Attribute, RFC 1997, August 1996.
A. Heffernan, Protection of BGP Sessions via the TCP MD5 Signature Option, RFC 2385, August 1998.
P. Marques and F. Dupont, Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routing, RFC 2545, March 1999.
E. Chen, Route Refresh Capability for BGP-4, RFC 2918, September 2000.
G. Huston, NOPEER Community for Border Gateway Protocol (BGP) Route Scope Control, RFC 3765, April 2004.
Y. Rekhter, T. Li, and S. Hares, A Border Gateway Protocol 4 (BGP-4), RFC 4271, January 2006.
S. Sangli, D. Tappan, and Y. Rekhter, BGP Extended Communities Attribute, RFC 4360, February 2006.
E. Rosen and Y. Rekhter, BGP/MPLS IP Virtual Private Networks (VPNs), RFC 4364, February 2006.
T. Bates, E. Chen, and R. Chandra, BGP Route Reflection: An Alternative to Full Mesh Internal BGP (IBGP), RFC 4456, April 2006.
E. Chen and V. Gillet, Subcodes for BGP Cease Notification Message, RFC 4486, April 2006.
T. Bates, R. Chandra, D. Katz, and Y. Rekhter, Multiprotocol Extensions for BGP-4, RFC 4760, January 2007.
Q. Vohra and E. Chen, BGP Support for Four-octet AS Number Space, RFC 4893, May 2007.
V. Gill, J. Heasley, D. Meyer, P. Savola, and C. Pignatoro, The Generalized TTL Security Mechanism (GTSM), RFC 5082, October 2007.
J. Scudder and R. Chandra, Capabilities Advertisement with BGP-4, RFC 5492, February 2009.
E. Chen, J. Scudder, P. Mohapatra, and K. Patel, Revised Error Handling for BGP UPDATE Messages, RFC 7606, August 2015.
MRT routing information export format, draft-ietf-grow-mrt-17, August 2011.
J. Dong, M. Chen, and A. Suryanarayana, Subcodes for BGP Finite State Machine Error, RFC 6608, May 2012.
J. Heitz, J. Snijders, K. Patel, I. Bagdonas, and N. Hilliard, BGP Large Communities Attribute, RFC 8092, February 2017.
J. Snijders, J. Heitz, and J. Scudder, BGP Administrative Shutdown Communication, draft-ietf-idr-shutdown, January 2017.
bgpd program first appeared in
|February 19, 2017||OpenBSD-6.1|