|ZRC(4)||Device Drivers Manual (zaurus)||ZRC(4)|
zrc — Zaurus
remote control support
zrc0 at pxaip?
wskbd* at zrc?
zrc driver provides support for the
CE-RH2 remote control that can be plugged into the headphone jack of the
Zaurus C1000, C3000, C3100, and C3200. Access to the additional keys
generated by the remote control is through the
In translated mode (when not running X) the keys generated by pressing the buttons on the remote control are:
In raw mode (when running X) the following keycodes are generated:
! Map to xmms control keys; mute becomes "shuffle" keycode 133 = s keycode 134 = Down keycode 135 = Up keycode 160 = z keycode 161 = b keycode 162 = x keycode 163 = v
To control applications that handle the standard audio keysyms, this configuration can be used instead:
! Map to standard audio keysyms keycode 133 = XF86AudioMute keycode 134 = XF86AudioLowerVolume keycode 135 = XF86AudioRaiseVolume keycode 160 = XF86AudioPrev keycode 161 = XF86AudioNext keycode 162 = XF86AudioPlay keycode 163 = XF86AudioStop
zrc driver first appeared in
|May 31, 2007||OpenBSD-6.0|