|ZKBD(4)||Device Drivers Manual (zaurus)||ZKBD(4)|
zkbd — Zaurus
zkbd0 at pxaip?
wskbd* at zkdb?
zkbd driver provides support for the
native keyboard found on the Zaurus. Access to the keyboard is through the
The Zaurus keyboard uses some strange chording behaviours to make certain key combinations show up. The left-hand Japanese key beside Ctrl (kana/hira) is mapped as the ALT key. The non-obvious key mappings are explained here:
On/Off is special: pressing the key will immediately suspend the system. Pressing the key while the Zaurus is suspended will cause it to resume. Pressing the key longer than 3 seconds will do a nice halt if the hw.allowpowerdown sysctl(8) variable is 1.
All keyboard input (including the On/Off key) is ignored if the display is shut.
zkbd driver appeared in
|June 24, 2011||OpenBSD-6.0|