|QUOTACHECK(8)||System Manager's Manual||QUOTACHECK(8)|
] filesystem ...
quotacheckexamines each filesystem, builds a table of current disk usage, and compares this table against that recorded in the disk quota file for the filesystem. If any inconsistencies are detected, both the quota file and the current system copy of the incorrect quotas are updated (the latter only occurs if an active filesystem is checked). By default, both user and group quotas are checked. Available options:
-aflag is supplied in place of any filesystem names,
quotacheckwill check all the filesystems indicated in /etc/fstab to be read-write with disk quotas. By default, only the types of quotas listed in /etc/fstab are checked.
quotacheckreports discrepancies between the calculated and recorded disk quotas.
-uis equivalent to the default. Parallel passes are run on the filesystems required, using the pass numbers in /etc/fstab in an identical fashion to fsck(8). Normally
quotacheckexpects each filesystem to be checked to have quota files named quota.user and quota.group located at the root of the associated file system. These defaults may be overridden in /etc/fstab. If a file is not present,
quotacheckwill create it.
quotacheckis normally run at boot time from the /etc/rc file (see rc(8)) before enabling disk quotas with quotaon(8).
quotacheckaccesses the raw device in calculating the actual disk usage for each user. Thus, the filesystems checked should be quiescent while
quotacheckcommand appeared in 4.2BSD.
|August 15, 2009||OpenBSD-6.0|