|PNINEK(4)||Device Drivers Manual (sparc)||PNINEK(4)|
— Weitek Power9000 accelerated frame
btcham0 at obio?
pninek0 at sbus?
wsdisplay* at pninek?
pninek is a color frame buffer with
graphics acceleration, embedded in the Tadpole SPARCbook 3 laptop. It is
based on the Weitek Power9000 video processor and a Brooktree Bt445
Due to specifics of the video hardware on the Tadpole SPARCbook 3, the complete driver is split in two parts:
The combination of both
pninek drivers interfaces the frame buffer with the
wscons(4) console framework.
They do not provide direct device driver entry points but make their
function available via the internal
If the tctrl(4)
device is also configured, the
pninek will be
powered down when the lid of the laptop is closed or the screen is
There is currently no way to switch back and forth from the onboard display to the external connector.
It is not possible to change display resolution.
Acceleration code does not work correctly, and is therefore disabled.
|November 21, 2015||OpenBSD-6.0|