|ZS(4)||Device Drivers Manual (macppc)||ZS(4)|
Zilog 8530 (ZSCC) serial communications driver
zs* at macobio?
zstty* at zs?
zs is a Zilog 8530 serial interface
chip used in Sun workstations and Apple Macintosh systems. On most newer
Macintosh systems, the first port tty00 is connected to the internal modem.
The second port is either not connected, or may be connected to an IRDA
device (untested). It is possible to replace the internal modem on some
system with a real serial port using third party hardware adapters.
zs driver supports all of the standard
tty(4) ioctl calls. The status
of the DTR, RTS, CTS, and DCD signals can be queried with TIOCMGET command,
but, due to limitations in the hardware, only the DTR and RTS signals can be
modified with TIOCMSET, TIOCMBIC, and TIOCMBIS
zs driver first appeared in
4.4BSD. Support for the TIOCM*
ioctl(2)s appeared in
zs driver now supports cua minor
devices, but with this known deficiency in the simultaneous
outgoing/incoming aspect of the driver: The first outgoing connection
succeeds, but second and subsequent connections fail, apparently due to a
getty hang. The hung getty apparently prevents the cua device from being
|November 23, 2015||OpenBSD-6.0|