|KGMON(8)||System Manager's Manual||KGMON(8)|
kgmon — generate a
dump of the operating system's profile buffers
kgmon is a tool used when profiling the
operating system. When no arguments are supplied,
kgmon indicates the state of per-CPU operating
system profilings as “running”, “off”, or
“not configured” (see
config(8)). If the
-p flag is specified,
extracts profile data from the operating system and produces a file for each
CPU suitable for later analysis by
The options are as follows:
-pflag is also specified, the profile files are generated before the buffers are reset.
-h is specified, the state of profiling collection
remains unchanged. For example, if the
-p flag is
specified and profile data is being collected, profiling will be momentarily
suspended, the operating system profile buffers will be dumped, and
profiling will be immediately resumed.
Users with only read permission on /dev/kmem cannot change the state of profiling collection. They can get profile files with the warning that the data may be inconsistent if profiling is in progress.
kgmon command appeared in
|March 12, 2013||OpenBSD-6.0|