|cpu(4/amd64)||Central Processing Unit|
|cpu(4/hppa)||HP PA-RISC CPU|
|cpu(4/i386)||Central Processing Unit|
|CPU(4)||Device Drivers Manual (amd64)||CPU(4)|
cpu — Central
cpu0 at mainbus?
cpu* at mainbus?
Several processor models have additional features that extend their base functionality, such as power and frequency control or thermal monitoring.
The sysctl(3) hw.cpuspeed will return the current operating frequency of the processor (on some processors this value may be an approximation). If possible, speed may be adjusted by altering hw.setperf from 0 to 100, representing percentage of maximum speed. There are several possible implementations for setperf, all transparent to the user.
The sysctl(3) hw.sensors.cpu*.temp0 will return the current temperature reported by the processor.
Due to the way in which thermal information is reported on Intel processors, the temperature may be off by exactly +/-15 degrees C.
For multiprocessor kernels with more than one CPU sensor, processors will report identical temperatures since the temperature is taken from the processor running the sensors update.
|July 13, 2009||OpenBSD-6.0|