|cgthree(4/sparc)||8-bit color frame buffer|
|cgthree(4/sparc64)||8-bit color frame buffer|
|CGTHREE(4)||Device Drivers Manual (sparc)||CGTHREE(4)|
cgthree — 8-bit
color frame buffer
cgthree* at sbus?
cgthree* at obio0 (some sun4m models)
wsdisplay* at cgthree?
cgthree is a color frame buffer,
available as an SBus card or on-board on some sun4c and sun4m workstations.
A small number of frame buffer SBus cards, not manufactured by Sun, are
cgthree-compatible and will also be recognized by the
cgthree driver interfaces the frame
buffer with the wscons(4)
console framework. It does not provide direct device driver entry points but
makes its functions available via the internal
cgthree frame buffer is used as the
console display, it is possible, for some models, to select a different
resolution than the default 1152x900 or 1024x768 by changing the OpenPROM
environment. To change the default resolution, type the following:
ok setenv output-device screen:r1152x900x66
to change to a 66Hz 1152x900 resolution.
cgthree frame buffer
is a secondary display, or a serial console is used, the display resolution
cannot be changed without using an
script. Refer to the
Sun Frame Buffer
FAQ for details.
cgthree frame buffer accepts the
Note that not all models support settings other than their default setting.
These frame buffers are cgthree-compatible cards with a VGA-compatible video connector. There are only two resolutions supported, selected by jumper JP2 on the card:
Sun Frame Buffer FAQ, http://www.sunhelp.org/faq/FrameBuffer.html.
|November 1, 2015||OpenBSD-6.0|