|BOOT_HPPA64(8)||System Manager's Manual (hppa64)||BOOT_HPPA64(8)|
hppa64 system bootstrapping procedures
When powered on, after a panic, or if the system is rebooted via reboot(8) or shutdown(8), the hppa firmware (“PDC”) will proceed to its initialization, and will boot an operating system if autoboot is enabled.
System boot blocks are provided as a “LIF” (Logical Interchange Format) archive, either on a disk, tape or CD-ROM device, or via the network, using the bootp protocol. A small mkboot(8) utility is provided for combining primary boot and a number of images (OS kernels or standalone binaries) into one “LIF” volume suitable for booting.
If autoboot is enabled, the PDC will attempt to boot from the specified “boot path” value. If no “boot path” has been specified, the PDC will then scan for bootable devices and boot from the first found, after a few seconds allowing the user to interrupt the boot process. If autoboot is disabled, the PDC will enter interactive mode, after an optional device scan. In all cases, it is possible to enter interactive mode by holding the escape key during the selftests, or when prompted to do so to abort the current operation, unless the PDC has been configured in “secure mode”.
“ISL” stands for “Initial System Loader” and is the boot(8) program in OpenBSD. On all versions of the PDC the “boot” command (see below) will be followed by the question: “Interact with IPL (Y, N, or Cancel)?>” where a positive answer will invoke an interactive prompt in the boot(8) program later and negative will thus suppress it. A cancellation will abort the boot process.
With the default behaviour being a non-interactive boot process.
There is only one interactive mode, with a BOOT_ADMIN> prompt, which provides both boot settings and commands. The complete list of commands depends on the machine and PDC version. The following list only mentions commands impacting the boot process.
auto bootis set to “on”, the PDC will always attempt to boot. The booted device chosen will depend on the
auto searchis set to “on”, the PDC will attempt to boot the first bootable device found in this order:
auto searchis set to “off” and the primary boot path points to a bootable device, no device scan will occur.
Note that setting
auto search to
“on” will force autoboot, regardless of the
auto boot value.
When invoked without parameters,
will list the various path settings.
The OpenBSD hppa boot loader program is extensively described in a separate document, boot(8).
If the system crashes, it will enter the kernel debugger, ddb(4), if it is configured in the kernel. If the crash occurred during initialization and the debugger is not present or is exited, the kernel will halt the system. If the crash occurred during normal operation and the debugger is not present or is exited, the system will attempt a dump to the configured dump device (which will be automatically recovered with savecore(8) during the next multi-user boot cycle), and after the dump is complete (successful or not) the kernel will attempt a reboot.
|May 31, 2007||OpenBSD-5.9|