|INIT(8)||System Manager's Manual||INIT(8)|
initprogram is the last stage of the boot process. It normally executes the sequence of events described in rc(8) and begins multi-user operation.
The kernel may pass the following options to
init, usually when requested by the
Single-user mode is also entered if the boot scripts fail.
In single-user mode, the
rc(8) script is not run and
normal daemons are not started, but instead a super-user shell is started on
the system console. If the console entry in the
ttys(5) file does not contain
the “secure” flag, then
require that the superuser password be entered before the system will start
a single-user shell. The password check is skipped if the
console is marked as “secure”.
In single-user mode, the system is quiescent for maintenance work
and may later be made to go to multi-user by exiting the single-user shell
(with ^D). This causes
init to run the
rc(8) startup command file in
fastboot mode (skipping disk checks).
The kernel securelevel(7) is normally set to 0 while in single-user mode, and raised to 1 when the system begins multi-user operations. This action will not take place if the securelevel is -1, and can be modified via the /etc/rc.securelevel script.
In multi-user operation,
processes for the terminal ports found in the file
init reads this file, and executes the command found
in the second field. This command is usually
getty opens and initializes the tty line and executes the
login program. The login program, when a
valid user logs in, executes a shell for that user. When this shell dies,
either because the user logged out or an abnormal termination occurred (a
init program wakes up, deletes the user
from the utmp(5) file of
current users and records the logout in the wtmp file. The
cycle is then restarted by
init executing a new
getty for the line.
Line status (on, off, secure, getty, or window information) may be
changed in the ttys file without a reboot by sending the
the command “
kill -s HUP 1”. On
receipt of this signal,
init re-reads the
ttys file. When a line is turned off in
init will send a
SIGHUP signal to the controlling process for the
session associated with the line. For any lines that were previously turned
off in the ttys file and are now on,
init executes a new getty to
enable a new login. If the getty or window field for a line is changed, the
change takes effect at the end of the current login session (e.g., the next
init starts a process on the line). If a line
is commented out or deleted from ttys,
init will not do anything at all to that line.
However, it will complain that the relationship between lines in the
ttys file and records in the utmp file
is out of sync, so this practice is not recommended.
init will terminate multi-user operations
and resume single-user mode if sent a terminate
TERM) signal, for example,
kill -s TERM 1”. If there are
processes outstanding that are deadlocked (because of hardware or software
init will not wait for them all to die
(which might take forever), but will time out after 30 seconds and print a
init will cease creating new
getty(8) and allow the system
to slowly die away, if it is sent a terminal stop
TSTP) signal, i.e., “
-s TSTP 1”. A later hangup will resume full multi-user
operations, or a terminate will start a single-user shell. This hook is used
by reboot(8) and
init will terminate multi-user operations,
kill all getty(8), and run
/etc/rc.shutdown if a user-defined signal 1
USR1), user-defined signal 2
USR2), or interrupt (
signal is received. Following this,
USR1 will halt
USR2 will request a powerdown; and
INT will cause a reboot.
/etc/rc.shutdown can specify that a powerdown is
requested instead of the action specified by the signal.
The role of
init is so critical that if it
dies, the system will reboot itself automatically. If, at bootstrap time,
init process cannot be located, the system will
panic with the message “panic: init died (signal %d, exit
initspawns a process it sets the process priority, umask, and resource limits based on /etc/login.conf. When starting the rc(8) files, the login class “daemon” is used. When starting a window system or getty(8), the login class “default” is used. No resource changes are made when entering single user mode.
initcommand appeared in Version 6 AT&T UNIX.
|September 4, 2011||OpenBSD-5.9|