|PORTMAP(8)||System Manager's Manual||PORTMAP(8)|
portmap — DARPA
port to RPC program number mapper
portmap is a server that converts RPC
program numbers into DARPA protocol port numbers. It must be running in
order to make RPC calls.
When an RPC server is started, it will tell
portmap what port number it is listening to, and
what RPC program numbers it is prepared to serve. When a client wishes to
make an RPC call to a given program number, it will first contact
portmap on the server machine to determine the port
number where RPC packets should be sent.
portmap must be started before any RPC
servers are invoked.
portmap forks and dissociates
itself from the terminal like any other daemon.
portmap then logs errors using
The options are as follows:
portmapfrom running as a daemon, and causes errors and debugging information to be printed to the standard error output.
portmap command appeared in
portmap crashes, all servers must be
|December 16, 2010||OpenBSD-5.8|