|SYSLOGD(8)||System Manager's Manual||SYSLOGD(8)|
syslogd — log
syslogd reads and logs messages to the
system console, log files, pipes to other programs, other machines and/or
users as specified by its configuration file.
The options are as follows:
syslogdto use only IPv4 addresses for UDP.
syslogdto use only IPv6 addresses for UDP.
syslogdshould place an additional log socket. Up to 20 additional logging sockets can be specified. The primary use for this is to place additional log sockets in /dev/log of various chroot filespaces, though the need for these is less urgent after the introduction of sendsyslog(2).
-uoption on a loghost with no DNS cache. Messages from the local host will still be logged with the symbolic local host name.
AF_LOCALsocket for use in reporting logs stored in memory buffers using syslogc(8).
syslogd reads its configuration file when
it starts up and whenever it receives a hangup signal. For information on
the format of the configuration file, see
syslogd creates the file
/var/run/syslog.pid, and stores its process ID
there. This can be used to kill or reconfigure
syslogd opens an Internet domain socket as
specified in /etc/services. Normally
syslogd will only use this socket to send messages
outwards, but in “insecure” mode it will also read messages
from this socket.
syslogd also opens and reads
messages from the UNIX-domain socket
/dev/log, and from the special device
/dev/klog (to read kernel messages).
syslogd opens the above described socket
whether or not it is running in secure mode. If
syslogd is running in secure mode, all incoming data
on this socket is discarded. The socket is required for sending forwarded
The message sent to
syslogd should consist
of a single line. The message can contain a priority code, which should be a
preceding decimal number in angle braces, for example,
“⟨5⟩”. This priority code should map into the
priorities defined in the include file
syslogd command appeared in
syslogd does not create files, it only
logs to existing ones.
|January 30, 2015||OpenBSD-5.7|