|MROUTED(8)||System Manager's Manual||MROUTED(8)|
mroutedis an implementation of the Distance-Vector Multicast Routing Protocol (DVMRP), an earlier version of which is specified in RFC 1075. It maintains topological knowledge via a distance-vector routing protocol (like RIP, described in RFC 1058), upon which it implements a multicast datagram forwarding algorithm called Reverse Path Multicasting.
mroutedforwards a multicast datagram along a shortest (reverse) path tree rooted at the subnet on which the datagram originates. The multicast delivery tree may be thought of as a broadcast delivery tree that has been pruned back so that it does not extend beyond those subnetworks that have members of the destination group. Hence, datagrams are not forwarded along those branches which have no listeners of the multicast group. The IP time-to-live of a multicast datagram can be used to limit the range of multicast datagrams. In order to support multicasting among subnets that are separated by (unicast) routers that do not support IP multicasting,
mroutedincludes support for "tunnels", which are virtual point-to-point links between pairs of
mrouteddaemons located anywhere in an internet. IP multicast packets are encapsulated for transmission through tunnels, so that they look like normal unicast datagrams to intervening routers and subnets. The encapsulation is added on entry to a tunnel, and stripped off on exit from a tunnel. By default, the packets are encapsulated using the IP-in-IP protocol (IP protocol number 4). Older versions of
mroutedtunnel use IP source routing, which puts a heavy load on some types of routers. This version does not support IP source route tunnelling. The tunnelling mechanism allows
mroutedto establish a virtual internet, for the purpose of multicasting only, which is independent of the physical internet, and which may span multiple Autonomous Systems. This capability is intended for experimental support of internet multicasting only, pending widespread support for multicast routing by the regular (unicast) routers.
mroutedsuffers from the well-known scaling problems of any distance-vector routing protocol, and does not (yet) support hierarchical multicast routing.
mroutedhandles multicast routing only; there may or may not be unicast routing software running on the same machine as
mrouted. With the use of tunnels, it is not necessary for
mroutedto have access to more than one physical subnet in order to perform multicast forwarding. The options are as follows:
mrouteddetaches from the invoking terminal. If this option is specified,
mroutedremains attached to the invoking terminal and responsive to signals from that terminal. If
-dis given with no argument, the debug level defaults to 2. Regardless of the debug level,
mroutedalways writes warning and error messages to the system log daemon. Debug levels have the following effects:
mroutedin a non-pruning mode. It is expected that a router would be configured in this manner for test purposes only. The default mode is pruning enabled.
mroutedautomatically configures itself to forward on all multicast-capable interfaces, i.e. interfaces that have the IFF_MULTICAST flag set (excluding the loopback "interface"), and it finds other
mrouteddirectly reachable via those interfaces. To override the default configuration, or to add tunnel links to other
mrouted, configuration commands may be placed in /etc/mrouted.conf. There are five types of configuration commands:
nameboundary-name | scoped-addr/mask-len
boundaryboundary-name | scoped-addr/mask-len
boundaryboundary-name | scoped-addr/mask-len
boundaryoption can accept either a name or a boundary; the
altnetoptions may be specified as many times as necessary. The
cache_lifetimeis a value that determines the amount of time that a cached multicast route stays in kernel before timing out. The value of this entry should lie between 300 (5 min) and 86400 (1 day). It defaults to 300. The
nameoption assigns names to boundaries to make configuration easier. The
phyintcommand can be used to disable multicast routing on the physical interface identified by local IP address local-addr, or to associate a non-default metric or threshold with the specified physical interface. The local IP address local-addr may be replaced by the interface name (e.g. le0). If a phyint is attached to multiple IP subnets, describe each additional subnet with the
altnetkeyword. Phyint commands must precede tunnel commands. The
pruningoption is provided for
mroutedto act as a non-pruning router. The
tunnelcommand can be used to establish a tunnel link between local IP address local-addr and remote IP address remote-addr, and to associate a non-default metric or threshold with that tunnel. The local IP address local-addr may be replaced by the interface name (e.g. le0). The remote IP address remote-addr may be replaced by a host name, if and only if the host name has a single IP address associated with it. The tunnel must be set up in the mrouted.conf files of both routers before it can be used.
boundaryallows an interface to be configured as an administrative boundary for the specified scoped address. Packets belonging to this address will not be forwarded on a scoped interface. The boundary option accepts either a name or a boundary spec.
metricis the "cost" associated with sending a datagram on the given interface or tunnel; it may be used to influence the choice of routes. The metric defaults to 1. Metrics should be kept as small as possible, because
mroutedcannot route along paths with a sum of metrics greater than 31.
rate_limitallows the network administrator to specify a certain bandwidth in Kbits/second which would be allocated to multicast traffic. It defaults to 500Kbps on tunnels, and 0 (unlimited) on physical interfaces.
thresholdis the minimum IP time-to-live required for a multicast datagram to be forwarded to the given interface or tunnel. It is used to control the scope of multicast datagrams. (The TTL of forwarded packets is only compared to the threshold, it is not decremented by the threshold. Every multicast router decrements the TTL by 1.) The default threshold is 1. In general, all
mroutedconnected to a particular subnet or tunnel should use the same metric and threshold for that subnet or tunnel.
mroutedwill not initiate execution if it has fewer than two enabled virtual interfaces (vifs), where a vif is either a physical multicast-capable interface or a tunnel. It will log a warning if all of its vifs are tunnels; such an
mroutedconfiguration would be better replaced by more direct tunnels (i.e. eliminate the middle man).
# # mrouted.conf example # # Name our boundaries to make it easier. name LOCAL 126.96.36.199/16 name EE 188.8.131.52/16 # # le1 is our gateway to compsci, don't forward our # local groups to them. phyint le1 boundary EE # # le2 is our interface on the classroom net, it has four # different length subnets on it. # Note that you can use either an ip address or an # interface name phyint 172.16.12.38 boundary EE altnet 172.16.15.0/26 altnet 172.16.15.128/26 altnet 172.16.48.0/24 # # atm0 is our ATM interface, which doesn't properly # support multicasting. phyint atm0 disable # # This is an internal tunnel to another EE subnet. # Remove the default tunnel rate limit, since this # tunnel is over Ethernets. tunnel 192.168.5.4 192.168.55.101 metric 1 threshold 1 rate_limit 0 # # This is our tunnel to the outside world. # Careful with those boundaries, Eugene. tunnel 192.168.5.4 10.11.12.13 metric 1 threshold 32 boundary LOCAL boundary EE
mroutedresponds to the following signals:
mrouted. The configuration file is reread every time this signal is evoked.
mroutedwas invoked with a non-zero debug level).
mroutedwrites its process ID to /var/run/mrouted.pid upon startup.
Virtual Interface Table Vif Local-Address Metric Thresh Flags 0 184.108.40.206 subnet: 36.2 1 1 querier groups: 220.127.116.11 18.104.22.168 pkts in: 3456 pkts out: 2322323 1 22.214.171.124 subnet: 36.11 1 1 querier groups: 126.96.36.199 188.8.131.52 184.108.40.206 pkts in: 345 pkts out: 3456 2 220.127.116.11 tunnel: 18.104.22.168 3 1 peers: 22.214.171.124 (2.2) boundaries: 239.0.1 : 239.1.2 pkts in: 34545433 pkts out: 234342 3 126.96.36.199 tunnel: 188.8.131.52 3 16 Multicast Routing Table (1136 entries) Origin-Subnet From-Gateway Metric Tmr In-Vif Out-Vifs 36.2 1 45 0 1* 2 3* 36.8 184.108.40.206 4 15 2 0* 1* 3* 36.11 1 20 1 0* 2 3* . . .
mroutedis the one responsible for sending periodic group membership queries on the vif 0 and vif 1 subnets, as indicated by the "querier" flags. The list of boundaries indicate the scoped addresses on that interface. A count of the number of incoming and outgoing packets is also shown at each interface. Associated with each subnet from which a multicast datagram can originate is the address of the previous hop router (unless the subnet is directly- connected), the metric of the path back to the origin, the amount of time since we last received an update for this subnet, the incoming vif for multicasts from that origin, and a list of outgoing vifs. "*" means that the outgoing vif is connected to a leaf of the broadcast tree rooted at the origin, and a multicast datagram from that origin will be forwarded on that outgoing vif only if there are members of the destination group on that leaf.
mroutedalso maintains a copy of the kernel forwarding cache table. Entries are created and deleted by
mrouted. The cache tables look like this:
Multicast Routing Cache Table (147 entries) Origin Mcast-group CTmr Age Ptmr IVif Forwvifs 13.2.116/22 220.127.116.11 3m 2m - 0 1 >18.104.22.168 >22.214.171.124 138.96.48/21 126.96.36.199 5m 2m - 0 1 >188.8.131.52 128.9.160/20 184.108.40.206 3m 2m - 0 1 >220.127.116.11 198.106.194/24 18.104.22.168 9m 28s 9m 0P >22.214.171.124
|September 8, 2014||OpenBSD-5.7|