OpenBSD manual page server

Manual Page Search Parameters

TCTRL(4) Device Drivers Manual (sparc) TCTRL(4)

tctrlTadpole Microcontroller Interface

tctrl0 at obio0

The tctrl driver provides control over many functions on the Tadpole SPARCbook 3 series laptops, via their TS102 chip.

The microcontroller is used to power the TFT display down when the laptop lid is closed and when the screen is blanked by the pninek(4) or pnozz(4) driver. The tctrl is also used to power the laptop off when the reboot(2) system call is used with the RB_POWERDOWN flag is set.

The PCMCIA part of the controller is managed by the tslot(4) driver.

The tctrl driver provides an interface which simulates the Advanced Power Management (APM) BIOS functions encountered on some x86 hardware. The BIOS functions are translated into the appropriate microcontroller requests. Currently only battery level, AC connection, and charging status are available from the tctrl device. Suspend/resume and other power events are not yet supported.

The tctrl driver implements the following ioctl(2) calls. They are defined in <machine/apmvar.h>.

(struct apm_power_info) Request the current power state. The argument structure is as follows:
struct apm_power_info {
	u_char battery_state;
	u_char ac_state;
	u_char battery_life;
	u_char spare1;
	u_int minutes_left;
	u_int spare2[6];
};

The following values are defined for battery_state:

Battery has a high state of charge.
Battery has a low state of charge.
Battery has a critical state of charge.
Battery is not high, low, or critical and is currently charging.
Can not read the current battery state.
No battery installed.

The following values are defined for ac_state:

External power not detected.
External power detected.

The battery_life value contains the estimated percentage of battery life available. 100% indicates a full charge.

The minutes_left value is always -1, as the hardware does not provide an estimated number of minutes of battery life remaining.

(int) This ioctl(2) controls message output by the tctrl driver when a power change event is detected. The integer parameter is one of:
All power change events result in a message. This is the normal operating mode for the driver.
Power change event messages are suppressed.
Power change event messages are suppressed unless the estimated battery life percentage changes.

/dev/apm
APM data device. May only be opened read-only. May be opened by multiple concurrent users.
/dev/apmctl
APM control device. May be opened read-write or write-only. May only be opened by one user at a time. An attempt to open the file when in use will fail, returning EBUSY.

reboot(2), intro(4), pninek(4), pnozz(4), tslot(4), apm(8), apmd(8)

Not all power management functions of the microcontroller are supported.

January 21, 2014 OpenBSD-5.6