|HD(4)||Device Drivers Manual (hp300)||HD(4)|
hd — CS/80 disk
hd* at hpibbus?
This is a generic CS/80 disk driver. Only a small number of possible CS/80 drives are supported, but others can easily be added by adding tables to the driver.
The driver interrogates the controller to determine the type of drive attached. The driver recognizes the following drives: 7912, 7914, 7933, 7936, 7937, 7945, 757A/B, 7958A/B, 7959B, 7962, 7963, 9122, 9134, 7912, 7936, and 9122, not all of which have been tested.
CS/80 drives have 256 byte sectors which are mapped to 512 byte ``sectors'' by the driver. Since some CS/80 drives have an odd number of sectors per cylinder, the disk geometry used is not always accurate.
A program to analyze the logged error information (even in its present reduced form) is needed.
|June 2, 2013||OpenBSD-5.5|