|HPIBBUS(4)||Device Drivers Manual (hp300)||HPIBBUS(4)|
hpibbus — HP-IB
hpibbus* at nhpib?
hpibbus* at fhpib?
hd* at hpibbus? (disks)
ct* at hpibbus? (cartridge tapes)
mt* at hpibbus? (9-track tapes)
ppi0 at hpibbus? slave 5 punit 0 (plotter)
HP-IB is essentially an IEEE 488 bus, with an HP command set (CS/80 on ‘newer’ devices, Amigo on before-the-early-1980s devices) thrown on top. Devices that respond to CS/80 (and probably Amigo, too) are tagged with a 16-bit ID.
HP-IB has a 2-level addressing scheme: slave, the analog of a SCSI ID, and punit, the analog of a SCSI LUN.
The CS/80 ID is unique to the slave, and is shared by all its punits. Most devices only have one punit; multiple punits are often used for disk drives that have an accompanying tape drive on the second punit, or for dual floppy drives.
In addition, not all HP-IB devices speak CS/80 or Amigo. Examples of such devices are HP-IB plotters, which simply take raw plotter commands over 488. These devices do not have ID tags, and often the host cannot even tell if such a device is attached to the system.
|April 1, 2008||OpenBSD-5.5|