OpenBSD manual page server

Manual Page Search Parameters

TVTOHZ(9) Kernel Developer's Manual TVTOHZ(9)

tvtohztranslate time period to timeout delay

#include <sys/types.h>
#include <sys/time.h>
#include <sys/systm.h>

int
tvtohz(const struct timeval *tv);

The () function computes the number of hz in the specified amount of time. This is mainly used to translate a timeval into a suitable argument for timeout(9).

This function is implemented in the file sys/kern/kern_clock.c.

hz(9), hzto(9), timeout(9)

August 20, 2010 OpenBSD-5.1