OpenBSD manual page server

Manual Page Search Parameters

HZTO(9) Kernel Developer's Manual HZTO(9)

hztotranslate absolute time to timeout delay

#include <sys/types.h>
#include <sys/time.h>
#include <sys/systm.h>

int
hzto(const struct timeval *tv);

The () function computes the number of hz until the specified time occurs. This is mainly used to translate a timeval into a suitable argument for timeout(9).

This function is implemented in the file sys/kern/kern_clock.c.

hz(9), timeout(9), tvtohz(9)

August 20, 2010 OpenBSD-5.1