|SMTPCTL(8)||System Manager's Manual||SMTPCTL(8)|
||command [argument ...]|
smtpctlprogram controls smtpd(8). Commands may be abbreviated to the minimum unambiguous prefix; for example,
The following commands are available:
removeenvelope-id | message-id
schedule-idenvelope-id | message-id
smtpd receives a message, it
generates a message-id for the message, and one
envelope-id per recipient. The
message-id is a 32-bit random identifier that is
guaranteed to be unique on the host system. The
envelope-id is a 64-bit unique identifier that encodes
the message-id in the 32 upper bits and a random
envelope identifier in the 32 lower bits.
A command which specifies a message-id applies to all recipients of a message; a command which specifies a envelope-uid applies to a specific recipient of a message.
smtpctlprogram first appeared in OpenBSD 4.6.
|February 9, 2012||OpenBSD-5.1|