|SMTPD(8)||System Manager's Manual||SMTPD(8)|
smtpdis a Simple Mail Transfer Protocol (SMTP) daemon which can be used as a machine's primary mail system.
smtpdcan listen on a network interface and handle SMTP transactions; it can also be fed messages through the standard sendmail(8) interface. It can relay messages through remote mail transfer agents or store them locally using either the mbox or maildir format. This implementation supports SMTP as defined by RFC 5321 as well as several extensions. A running
smtpdcan be controlled through smtpctl(8).
The options are as follows:
smtpdwill run in the foreground and log to stderr.
-dflags are specified. The only accepted value is imsg, which displays the messages exchanged between the various
smtpd is not enabled by default. In order
to use it as the system mailer, ensure the mail queue is empty, then stop
# pkill sendmail
Modify the current mailwrapper(8) settings by editing /etc/mailer.conf:
sendmail /usr/sbin/smtpctl send-mail /usr/sbin/smtpctl mailq /usr/sbin/smtpctl makemap /usr/libexec/smtpd/makemap newaliases /usr/libexec/smtpd/makemap
Rebuild the aliases database, and enable the daemon:
# newaliases # echo "sendmail_flags=NO" >> /etc/rc.conf.local # echo "smtpd_flags=" >> /etc/rc.conf.local # smtpd
Simple Mail Transfer Protocol, RFC 5321, October 2008.
smtpdprogram first appeared in OpenBSD 4.6.
|October 22, 2011||OpenBSD-5.1|