|RTADVD(8)||System Manager's Manual||RTADVD(8)|
rtadvd — router
rtadvd sends router advertisement packets
to the specified interfaces.
The program will daemonize itself on invocation. It will then send router advertisement packets periodically, as well as in response to router solicitation messages sent by end hosts.
Router advertisements can be configured on a per-interface basis, as described in rtadvd.conf(5).
If there is no configuration file entry for an interface, or if
the configuration file does not exist at all,
sets all the parameters to their default values. In particular,
rtadvd reads all the interface routes from the
routing table and advertises them as on-link prefixes.
rtadvd also watches the routing table. By
default, if an interface direct route is added/deleted on an advertising
interface and no static prefixes are specified by the configuration file,
rtadvd adds/deletes the corresponding prefix to/from
its advertising list, respectively. The
may be used to disable this behavior. Moreover, if the status of an
advertising interface changes,
rtadvd will start or
stop sending router advertisements according to the latest status.
Basically, hosts MUST NOT send Router Advertisement messages at
any time (RFC 2461, Section 6.2.3). However, it would sometimes be useful to
allow hosts to advertise some parameters such as prefix information and link
rtadvd can be invoked if router lifetime
is explicitly set to zero on every advertising interface.
The command line options are:
rtadvdwill run in the foreground and log to stderr.
rtadvdtries to join the first advertising interface appearing on the command line. This option has meaning only with the
-Roption, which enables routing renumbering protocol support.
rtadvdwith a warning message.
Upon receipt of signal
rtadvd will dump the current internal state into
SIGTERM to kill
rtadvd gracefully. In this case,
rtadvd will transmit router advertisement with
router lifetime 0 to all the interfaces (in accordance with RFC 2461
rtadvd utility exits 0 on
success, and >0 if an error occurs.
rtadvd command first appeared in the
WIDE Hydrangea IPv6 protocol stack kit.
There used to be some text that recommended users not to let
rtadvd advertise Router Advertisement messages on an
upstream link to avoid undesirable
icmp6(4) redirect messages.
However, based on later discussion in the IETF IPng working group, all
routers should rather advertise the messages regardless of the network
topology, in order to ensure reachability.
|September 3, 2010||OpenBSD-5.1|